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CHAPTER 1 — NAV IGAT ION AND
STANDARD DASHBOARDS
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1 . 1 STANDARD DASHBOARDS

To access dashboards, click theMain menu icon at the top. Click Explore, and then select Dashboards.

You do not have to be signed in to a project or assigned to a particular project to access Explore.
Explore is available to all users in an organization that have been assigned the applicable role or
permissions and is a separate application from those used in any given project level. The information
provided in Explore is not in real time for any given project.

There are multiple out-of-the-box dashboards available in Explore with each having its own refresh
schedule, which is determined by the product groups.

Dashboard Description

Advanced
Work
Packaging

Leverages the Advanced Work Packaging interface to provide insights into
your construction work areas, packages, and individual work plans. Provides
granular visibility into Field Execution Plans and helps you understand any
constraints such as labor, equipment, material readiness that are impacting
your project, how work is being planned, and how the project is progressing
in terms of your schedule.

Change Issue Provides insights into project changes and allows project teams to see the
different stages of these changes that are initiated as Issues to become
PCOs (Potential Change Orders), and then CCOs (Client Change Orders).
All the relevant metrics about Issues, PCOs, and CCOs are shown with the
ability to filter the data down by organization, project, and date range. The
data in this dashboard is sourced from InEight Change to help you
understand trends over time, counts, and values associated to contract
changes.

Connected
Analytics Index

Provides a catalog of all reporting items contained in Report, Explore and
Replicate. This dashboard helps you locate the specific data fields in InEight
Reporting APIs and provides updated schema information for each Explore
and SelfService API, and Replicate view when your environment upgrades to
a new release.

Connected
Analytics
Utilization

Provides metrics to show utilization by users over time that helps to identify
level of engagement with InEight Report and Explore applications. Also
provides information on the functionality of the reports that were run.
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Dashboard Description

Contract Allows you to track your contracts throughout the entire contract lifecycle and
provides a single focal point where you can manage contracts and drive
action where it is needed. This dashboard can also be launched directly from
the Actions menu in InEight Contract.

Control Offers clear insights into budget performance with Earned Value metrics
such as CPI, SPI, PF, and Variances. Visualize Cost, Manhour and Revenue
curves pinpoint shortfalls and critical cost items, enabling proactive
adjustments to keep projects on track or minimize deviations.

Control Audit Allows you to track the changes that occurred in the CBS, ACS, Pay Items,
and Change Register pages in InEight Control. In the dashboard, you can
see who made changes, the items that were changed, and the value amounts
in the change. Information captured in the dashboard also lets you to see
when a sync between Control and external systems was performed.

Core Project Provides a comprehensive overview of platform-level items, including
organizations, projects, roles, permissions, user role assignments, and
logins. This dashboard also provides insights into utilization of each InEight
application in the cloud platform by showing the total number of main objects
such as the total issue count in Change or cost items in Control.

Estimate Provides summary of upcoming bid, bid result and the ratio between bid to
hit.

Field
Execution

A productivity centric dashboard that offers a comprehensive analysis on the
field performance. Metrics ranging from Progress Curves, Planned vs Actual,
Daily Gain/Loss, Cost/Hours Productivity, Crew Performance, Timesheet
Exceptions, Issues and more are available to help identify bottlenecks and
proactively make informed decisions to mitigate deviations from project
budget. The Time Intelligence filters such as Next Week, Next 3 weeks or
Next Month provide users the ability to see future productivity targets, which
helps with resource planning.

Manhour
Curves

Designed to supplement the Manhour Curves report that is found in InEight
Report. The report is very heavily used, but it does not allow for certain
changes to be made that can closer suit your business processes. The date
slicer at the top allows you to customize the date range, and the curves slicer
allows you to select the curves you want to see (earned, actuals, budget,
forecast, etc.).
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Dashboard Description

Material
Tracking

Allows visibility to see components that do not have materials associated
with them and where materials are for work plans that are not ready. In the
dashboard you can open a work plan that is marked as not ready, and then
drill down to view the components that are missing materials or select
another tab to see where material is not assigned to a component.

Model Tracked
Issue

This dashboard highlights Issues captured in InEight Model, enabling
effective management and prioritization. It provides key details such as due
dates, responsible parties, categories, and more to streamline issue
resolution.

Operations Provides an analysis of daily plan performance across the lifespan of a
project. Sorts by approver and executor to view the performance of their
work. Also measures the work by both account code and CBS position.
Various tabs are available in the dashboard for visualizing daily plan
performance data.

Package
Milestone

Allows you see information about user-defined milestones in the procurement
process over time. Also provides detailed bid package information at the line
item level with the ability to link back to InEight products.

Portfolio Consolidating data from multiple InEight applications, this dashboard helps
you understand how your projects are progressing and identify areas that
might need attention sooner rather than later. The dashboard highlights key
metrics and data for your project from Control, Contract, Change, Plan,
Progress, and Platform, and shows it in one centralized location. From this
information, you can understand the overall health of your projects or utilize
this dashboard to compare milestones across.

Project
Controls

An earned value-centric dashboard that provides a detailed and holistic view
of budget performance. This dashboard encompasses all key EV metrics,
including budgets, estimates, forecasts, actuals, revenues, changes, and
resources that provides valuable insights to help track and manage financial
performance throughout the project lifecycle. By visualizing these metrics in
one place, the dashboard enables teams to assess trends, identify variances,
and make data-driven decisions to maintain control over costs and
resources. This dashboard also facilitates a Data Integrity Health Check,
pinpointing exceptions and inconsistencies—an essential feature for
maintaining robust and reliable cost management within InEight Control.
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Dashboard Description

Project
Performance

Allows for the selection of multiple projects to see earned versus actual
comparisons of cost and manhours. Also shows CE and CB information by
cost item or account code and provides a list of change order details and the
totals of cost and budget adjustment from the items.

Schedule Provides comprehensive insights into project schedules, offering detailed
activity and schedule comparisons, float trend analysis, and resource
utilization tracking. It includes high-level risk and opportunity overviews,
deeper analyses of threats and mitigations, and a centralized event register.
With industry-standard schedule quality metrics and tools to evaluate
mitigation efforts, this dashboard ensures users can trust their data while
identifying risks, opportunities, and areas requiring attention across progress
updates or what-if scenarios.

Work Planning Utilizes the Advanced Work Packaging module to deliver detailed insights
into construction areas, construction work packages, and specific plans
(IWPs). Offers a clear view of field execution plans while highlighting
constraints such as workforce, equipment, and materials that might affect
progress. This dashboard provides a better understanding of how tasks are
being organized and the project’s advancement relative to the timeline.

1.1.1 Dashboard Management

This Explore settings page lets administrators hide dashboards at the organization level, control the
dashboard refresh schedule, and initiate a dashboard refresh on demand. You must have the role of
Organization Admin (or above) and the required permissions to view and access the Dashboard
Management page.
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Dashboard Management

1. To manage dashboards, click theMain menu icon ( ), and then select an organization.

2. Go to Settings > Explore > Dashboard Management.

The page shows a list of the organization dashboards where you can do the following:

l Set to show or hide the dashboard for the organization

l See the dashboard refresh status. If the status is Failed, click the link to view the error
message

l See the average refresh time to help when adjusting schedules and to avoid having
multiple dashboards refresh at the same time.

The Refresh user data button lets an administrator refresh user data in the background. For
example, Explore users that are granted new permissions and need access to in-app dashboards
right away. Normally, a user would have to wait for the overnight refresh to be able to view
dashboards.

3. To define the refresh schedule, click Set schedule. The Dashboard refresh slide-out panel opens.
At the top it shows the number of times per day that the dashboard can be refreshed.
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4. Set the Refresh schedule toggle to view and make changes to the settings. You can click Refresh
now to manually refresh the selected dashboard. A manual refresh does not count towards the
available number of daily scheduled refreshes.

5. Click Save to set the refresh schedule.

1 . 2 EXPLORE PERMISS IONS

To access dashboards and APIs, you must be assigned a role with applicable permissions, which are
defined by a system administrator. Permissions are pre-assigned to roles that are based on functional
areas, such as project management, construction management, field office, operations, finance,
compliance, and administration that let you run reports tagged with the same permission assigned to
one of the roles. For more details, refer to Roles and Permissions in InEight Platform. Permissions are
configured in Suite Administration > Roles and permissions > Permissions > Explore.

Permission
Name Description Level

View shared
dashboards
and
embedded

Allows users to see only dashboards and embedded content that
has been shared with them individually. This will hide all standard
dashboards for users with this permission.

Base
user
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Permission
Name Description Level

content only

View
dashboards
and
embedded
content

Allows users to view standard dashboards (data level permissions
are allowed to the projects users are assigned to in Platform),
custom dashboards that have been shared with them, add/edit
external content, and view external content that has been shared
with them. This permission also gives users access to create, edit,
and delete their own folders (these folders are only available at the
individual user level). This permission is the parent of all other
permissions in Explore > Dashboards.

Base
user

View estimate
dashboard

Allows users to view the Estimate dashboard and any other custom
derivatives of this dashboard that have been shared with them.

Base
user

Edit and
delete
custom
dashboards

Allows you to edit and save custom versions of the standard
dashboards, this permission does not give sharing access. This
permission is necessary for you to be added as a collaborator on a
dashboard that is shared. Allows users to edit and save custom
versions of the standard dashboards, this permission does not
give sharing access. This permission is necessary for a user to be
added as a collaborator on a dashboard shared with them.

Base
user

User level
sharing

Allows users to share your custom dashboards and embedded
content with other individual users.

Base
user

Project level
sharing

Allows users to share their custom dashboards and embedded
content with all the users on a project, users can only do this for
projects they are assigned to in Platform.

Project
Admin

Organization
level sharing

Allows users to share their custom dashboards and embedded
content with all the users in an organization, users can only do this
for organizations they are assigned to in Platform.

Org
Admin

Reporting
APIs

Allows a user to access to all the data in the reporting APIs for the
selected products.

Base
user

Access
Explore
settings

Allows users to access and utilize all the functionality on the
Organization Settings > Explore page. This page allows users to
control the visibility of dashboards for the whole organization, as
well as the dashboard refresh schedules, and execute ad hoc

Org
Admin
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Permission
Name Description Level

refreshes. This permission also grants users access to see every
custom dashboard built in the environment when in the Explore
application.

1 . 3 DASHBOARD FOLDERS

In Explore, you can create folders to organize the various types of dashboards you create. This can help
to easily identify dashboards you may refer to on a weekly basis versus monthly basis or dashboards
you create for an executive level versus a field operations level. In a later lesson, you will learn how to
modify and create these additional dashboards.

1.3.1 Folder Creation

The following Step by Step walks through the two ways you can create a dashboard folder.

Create dashboard folders

Opt ion 1:

1. From the Dashboards page, click the Add Folder icon to add a folder.

l A dialog box opens and prompts you to name the folder

2. In the Save Folder As field, type Example Folder, and then click Save.
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l The new folder will now show on the left panel as shown below.

Opt ion 2:

1. Click the three Ellipses Context menu icon to the right of the new Example Folder.

l A slide-out panel opens

2. Click Add Folder.

3. In the Save folder As field, type Example Folder 2, and then click Save.
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l A sub-folder has been created

Besides adding folders, you can edit, share, move, set as the default dashboard or
delete the dashboard via this same Context menu icon.

1.3.2 Move Dashboards to a Folder

The following steps walk you through how to move a dashboard into a folder.
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Move a dashboard into a folder

1. From the Dashboards page, click the three-ellipses Context menu icon of the Operations
dashboard.

2. ClickMove into Folder.

l A dialog box opens with a drop-down list to select the folder for which you want to move
the dashboard into

3. Click the drop-down arrow, and then select Example Folder.
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4. Click Save.

l The Operations dashboard will now be located within the Example folder

You can use the same Context menu icon to remove a dashboard from a folder.

1 . 4 DASHBOARD FAVOR ITES

You can mark one or more dashboards as your favorite by clicking the Favorites icon on the right side
of any dashboard. This can be done on the two system-created dashboards or any dashboards you
create. This is a convenient way to access dashboards that you use often.

Click the Favorites icon next to the Project Performance dashboard.

The dashboard now shows up under the Favorites header when selected from the drop-down
list. The star remains yellow.
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1 . 5 DASHBOARD SHAR ING AND
COLLABORAT ION

The concept behind sharing a dashboard evolved as a means to save time and energy for those
working together who share similar data needs. Sharing a dashboard may be a perfect option when the
original dashboard doesn’t need to be edited by the person who is viewing the shared dashboard.
Collaboration goes a step further by granting the person with whom the dashboard is shared,
permission to collaborate on and edit the dashboard. Think of collaboration as a subset of sharing,
meaning you cannot collaborate on a dashboard until the dashboard is able to be shared. Only system
dashboards that you personally have edited and renamed can be shared.

To share a system dashboard you must first save it as your default dashboard, re-save and re-name the
dashboard, and then you can share or collaborate.

The word "Default" after the dashboard name represents your default dashboard, and Sharing is
grayed out and unavailable as it is a default dashboard setting.
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1.5.1 Set a Dashboard as Your Default

Initially, no single dashboard in InEight Explore is considered your default dashboard. Until you choose
to share a dashboard, or collaborate with others, does it become an important function.

In order to share or collaborate with others on a dashboard you initiate, it must first be set as your
default dashboard.

To set or change a dashboard as your default:

1. Click the 3-dot ellipses on the right side of your desired dashboard.

2. Select Set as default.

• You have now set (or changed) your default dashboard

1.5.2 Share a Dashboard with Others

After a dashboard is shown as your default, the Sharing option becomes available to you.

The Operations Dashboard below does not have the Sharing option available as it is a System
dashboard and it has not yet been set as the default and re-named.
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Conversely, the personalized, re-named dashboard called Ops Dashboard – KL has the Sharing option
available.

Share a Customized System Dashboard

1. Select a system dashboard to share.

2. Click the 3 dot ellipses on the right side of the system dashboard name.

3. Click Set as Default.
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4. Click the 3 dot ellipses again.

5. Click Edit Dashboard.

6. Make edits and go to File > Save As.

7. Re-name the dashboard.

8. Click Save.

9. From the newly named dashboard, click the Sharing option.

10. Select with whom you would like to share the dashboard by selecting an option from the
drop-down list. Options include:
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l Organization
l Project
l Person

l For example, if you choose to add a person, you can begin typing the name of a
person’s email address to be guided to select an individual. A similar concept is
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available for Project and Organization

11. Click Share.
l A Dashboard Shared notification will briefly appear on the top of your screen
l Now, the Shared icon is visible to the right of the dashboard name

12.
Elevated permissions are required to share at the project and org level.

Use caution when using the Organization option, as all individuals will see this new
dashboard option upon their next sign-on to Explore.

With each new log in to Explore, newly shared dashboards will show the yellow New! tag next to the
dashboard name. Afterward, the New indicator will not show. Hovering over the Share icon indicates if
the dashboard is being shared with you, or if you are sharing the dashboard with others.

A black Share icon indicates a dashboard is shared by you.
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A blue Share icon indicates a dashboard is shared with you.

Click the blue Sharing icon to view the Sharing details for that specific shared dashboard. Click Close to
return to the dashboard.

While you cannot edit others’ dashboards, you can save your own copy of it and make your own
modifications to it. When changes are made by you, others whom you share the dashboard with will
also see your changes.

1.5.3 Collaborate on a Shared Dashboard with Others

Collaborating on a dashboard gives the person with whom the dashboard is shared not only the
permission to view it, but also to edit the file. Any changes made will be visible to all parties who have
access to the shared dashboard.

Using the process above, once you have gotten to the step of selecting who the dashboard will be
shared with, in our example, we'll be sharing the dashboard with just one person.

Checking the Can Edit box and then clicking Share provides the person, project or organization the
ability to collaborate with you on the shared dashboard.
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1.5.4 Remove Sharing

For any dashboard you create and share, you may also remove sharing. By hovering over the Sharing
icon, you can identify the reports you have shared with others.

Remove Sharing

1. Click the black Sharing icon.

2. Either select Remove all sharing to remove all people from sharing mode, or the click the
Remove Sharing red circles next to the names of those to remove.
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l This change is instantaneous
l A dialog box will briefly appear to confirm the removal has occurred

1.5.5 Embed External Content

Embedding external content in InEight Explore means you can expose dashboards you have on your
Power BI service or Tableau server in the InEight Explore application.

While your organization is still responsible for maintaining security and maintenance of the dashboards
and data behind them, you can have all your dashboards in one place and it eliminates the need to
bounce around different windows to look at dashboards that may contain more than just InEight
Application data.

Set-up Adding External Content

1. Click the Add External Content icon.
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2. In the dialog box, add the name for the new report, in addition to the Source for the
external content.

3. Click Save.

Click the Instruction icon to be taken to the Guide for embedding content in Explore.

l The resulting saved report appears alphabetically in your list of reports. The External
Content identifier is also shown.

l Clicking on this dashboard takes you to the https:// Source page shown above

4. Before leaving the page, and in the event you need to save this new report, click the Save
& Exit button.
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5. This allows you to type in a dashboard name, and then click Save.

6. Search for the resulting dashboard, again alphabetically.

1.5.5 .1 Dele t ing an Embedded Dashboard

As with other dashboards, dashboards with embedded external content can be deleted.
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Delete an Embedded Dashboard

1. From the list of dashboards, click on the desired dashboard to delete.

2. Click the Delete Dashboard icon.

3. You will be asked to confirm the deletion. Click Yes.

1.5.6 Share External Content

Sharing embedded content allows you to have one place to view all reporting and ensures that
everyone in your organization is looking at the same reporting.

Share External Content with Others

1. To share external content that you have already embedded into Explore, click the Sharing
icon, and then the vertical ellipses for the external content.
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2. Then in the dialog box, select the appropriate Organization, Project or Person from the
drop-down list to apply sharing.

3. When a dashboard is shared with you, if you already have a Power BI login, click Sign-In.
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4. To request access to a shared report, click the Request access button.

5. Depending on your authorization level, you may get another dialog box to request access.
Click OK.

6. You can add a personal note, and then click Send request.
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Clicking the Sharing icon of any dashboard that has been shared with you results in
a dialog box indicating the source, owner and created date for the share.

1 . 6 DASHBOARD EXAMPLES

The Package Milestone dashboard lets you see information about user-defined milestones in the
procurement process over time. A second tab details bid package information at the line item level
with the ability to link back to InEight products.
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Package Milesetone Dashboard

1. From the Dashboards page, click the Package Milestone dashboard.

2. Select a Project drop-down title.

l Note you may also scroll to search for a project or type in a project name in the
search bar to select a project

3. Click Select All.

4. Close the Dashboards panel.

l The summaries, graphs and data presented here are specific to this project

l You should see the updated Package Milestone dashboard as shown below

5. From the Milestone drop-down list, deselect all but the Delivery item.
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6. The graph now changes:

7. Change the Date Range to a shorter period of time.

8. Click the light blue colored Forecasted Cumulative column for the tallest month.  Your report
should look like something like this:
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9. Click the Focus icon for a better view of the graph.

10. Click < Back to Report to return to the main view.

11. Click the Filter icon, on the upper right side of the graph.

12. Notice now the two filters that appear, Date and MilestoneName. Click outside the box to close
the dialog box.
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Package Mi les tone Header Values

The following table provides explanation of scheduled, forecasted, actual and cumulative (scheduled,
forecasted and actual) packages at user-defined milestones.

Term Definition

Project Identifies the project.

Package Type Identifies the project options.

Milestone Identifies the user-defined step in the project.

Date Range Dates, as selected in the calendar.

Click the Schedule Detail tab at the bottom of the page.
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l In this view, line item level detail is available with the ability to link back to other InEight
applications. Filtering, sorting and adjusting column width are options available for further
ease in analysis.

Prev iewing Meta-data

Right-click on any header, and then select Visual table to view the meta-data further.

Detailed data will appear:

Press <Back to report to return to the default view.
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While some dashboard graphs offer the ability to Drill Up, Drill Down, Go to the Next Level of the
Hierarchy, and Expand all down one level in the Hierarchy, most other graphs include the following
options:

Term Definition

1 Filter Filters and slices data in a visual.

2 Focus mode Expand one visual in the dashboard.

3 More options Opens additional options.

4 Export Data Export data only to Excel (not visuals).

5 Show as a
Table

Shows data/chart in a larger view.

6 Spotlight Focuses dashboard on one specific visual.

7 Sort
descending

Sort data in descending order.

8 Sort
ascending

Sort data in ascending order.

9 Sort by Allows you to sort by status or form.
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1 . 7 AP I DOCUMENTAT ION

1.7.1 API Documentation Overview

From the home landing page, click theMain menu icon ( ), and then click Explore >
API Documentation.

A new browser window opens to the InEight Knowledge Library Explore Resources tab. In the API
Documentation section under the InEight product are the documents that represent each data
endpoint InEight offers for self-service reporting.

To access a report, in the API Documentation section, click the + icon for the product to expand the list,
and then select a file name. The document opens in a new browser window. Each API document
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includes an Overview of the selected API, a table of Relationships and Dependencies, Details,
Supported Filters, API Fields and Field Descriptions, along with a Sample and Data Validation when
applicable.
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CHAPTER 2 — CUSTOM
DASHBOARDS
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2 . 1 CUSTOM DASHBOARDS

In Explore, you can edit the standard dashboards in order to create new custom dashboards and
visualizations by modifying standard dashboards to meet the needs of your project. You cannot create
dashboards from scratch, but you can edit the standard dashboards and save them as new custom
dashboards.

2.1.1 Edit Dashboard

The following steps walk you through how to edit an existing dashboard to create a new dashboard.

Edit a dashboard

1. From the Dashboards page, click the Context menu ellipses next to the Operations
dashboard.

2. Select Edit dashboard.

3. The Visualization and Fields slide-out panels open on the right side of the screen.

l A yellow New page icon appears next to the page number at the bottom of the screen

4. Click the New page icon to add a new tab.
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l Your screen will now look something like this

5. Double-click on the default page name and type inman hours.

l Your tab will now look like this:

6. From the drop-down menu, click File > Save as.
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7. In the dialog box, name the custom dashboard, and then click Save.

2.1.2 Dashboard Customization

From the Visualizations and Fields slide-out panels, you can add chart, graph and card visualizations to
your dashboard and populate them with the appropriate data fields.

You cannot change the data source for the dashboard.  The dashboard comes pre-connected to a
dataset you may use to edit or add visualizations and filters.

Visualizations and Field slide-out panels are utilized for the following unique purposes:

Term Definition

1 Filters slide-out
panel

Various ways to cut the data using selections from the Fields slide-
out.

2 Bookmarks
slide-out panel

Customizable saved dashboard views to quickly access frequent
dashboards.

3 Visualizations
slide-out panel

Charts, Graphs, and Cards selection for dashboard tab.

Overview - Filters, Bookmarks, Visualizations and Fields Slide-Out Panels
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Term Definition

4 Charts/Graphs Various charts, graphs, an PowerApps for PowerBI.

5 Fields, Format,
Analytics

Format provides page information. Fields allows for adding value
data fields and drill through capability. Analytics modifies the lines
(min, max, average, etc.) shown in the selected chart or graph.

6 Fields slide-out
panel

Contains data fields to add to your visualizations to report on in your
dashboard.

7 Data Fields Data from InEight Project Suite to add to fields such as Axis, Legend,
Values, etc. under the Visualizations slide-out panel.

Overview - Filters, Bookmarks, Visualizations and Fields Slide-Out Panels (con-
tinued)

The following Step by Step walks you through adding a graph visualization to your dashboard reporting
on Project Progress and man hours.
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Create a graph

1. Under the tab you created in Step by Step above, on the Visualizations slide-out panel select the
Line chart visualization.

2. To make more space, hide the Dashboards slide-out panel, Filters slide-out panel and close
Bookmarks.

3. Enlarge the Fields slide-out panel by sliding the left border toward the left to increase the
Fields selection area.

Page 50 of 92 InEight Inc.  |  Release 26.1

2.1 Custom Dashboards Explore User Guide



4. Under the Fields slide-out panel, navigate to the Calendar and click the CalendarYearStr check
box, and the selection will populate in the Axis.

5. Close the Calendar Field and scroll down and open the CostItem Field side arrow.
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6. In the Search bar under Fields type C B-.

7. Select the C B – TotalMH check box to add it to the Values section of the Visualizations
slide-out.

8. Clear the Search bar and close the CostItem field.

9. Open the Daily Plan Summary Field and selectManHoursApprovedDate. Modify the Date
Hierarchy to match this:

10. Close the DailyPlanSummary field.

11. Expand the graph size by pulling the lower right corner of the graph downward.

12. Open PlanProjectProgressand select the following fields:
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a. ApprovedEarnedMHrsbyCBQtyCBMHrs

b. Cumulative ApprovedMHrsGLbyCBQtyCBMHrs

c. SubmittedEarnedMHrsbyCBQtyCBMHrs

l On the dashboard on the left, the graph displays your submitted earned man hours
and compares that against approved earned man hours 

13. By clicking each Values drop-down fields, you will see each is intuitively using the mathematical
sum function.

14. On the C B-TotalMH drop down, change the selection from Sum to Average.  Notice how the
field name changes.
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15. Open the Filter slide-out.
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16. Expand the CalendarYearStr field by clicking on the drop down. Using Basic filtering, select years
2018, 2019 and 2020 to abbreviate the reporting years chart.
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17. Right-click inside your chart and select Visual table.

Page 56 of 92 InEight Inc.  |  Release 26.1

2.1 Custom Dashboards Explore User Guide



l Your chart should look similar to this:

18. Click < Back to Report.

19. In the upper left corner, note the View options available in the drop-down. Change the
Show smart guides toggle to On. 

l Doing so makes a vertical bar appear each time it bisects a point in the graph
l Clicking on the bisected point brings up the data, as shown below 
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20. From the View drop-down, turn the Bookmarks Pane toggle to On.

2.1.3 Save Dashboard

There are two ways to save a dashboard.

First, if you are leaving a newly created report where you have modified data, you will receive a pop-up
where you can confirm your desire to save your change. 

Click the File > Save As drop down.

If Yes in selected, save with a new dashboard name and click Save.
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l Your dashboard will appear on the left slide-out panel alongside your other dashboard

Alternatively, if you are leaving an existing report where you have modified data, you will receive a
pop-up where you can confirm your desire to save a copy of your change. 

Click the File > Save As drop-down.

Add a name for the new dashboard and click Save.
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2.1.4 Dashboard Printing

To print a dashboard, select the three dot ellipses next to a dashboard you created. 

l The dashboard print settings will default the orientation to Portrait. At times, selecting
Landscape will provide a more full page view

To determine what fields are in a given report, click the Report, look at the Fields pull-out,
and open the yellow colored drop-down. Search through the listing for the field(s) with a
solid check-box.
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2.1.5 Add a Bookmark

From an edited dashboard, you are able to further personalize your dashboard by adding a new field.
In our example, Approver 1, Ajay GK is a frequent approver. We want to quickly view projects specific
to him. We will do that by adding a new field onto the dashboard then adding a new Bookmark tied to
him. That way, we can quickly see that view as easily as the default mode, or by clicking on other
default Bookmarks. Let’s see how we did it.

Add a bookmark

1. Ensure you are in the Edit dashboard mode of a saved, renamed dashboard.

2. Close the Dashboard pane by clicking the double blue arrows.

3. Search the Fields pane drop-down lists to locate the field to add, in our case under the
DailyPlanSummary, we selected Approver 1.

4. Drag that field onto the dashboard.
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5. Using the gray colored handles that surround each attribute, move and re-size it and/or
other attributes until the dashboard fits to your liking.

6. Highlight the desired Approver 1, in our case Ajay GK.

7. On the Bookmarks pane, click the Add icon, which will place a re-nameable bookmark at
the bottom of the Bookmark pane.
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8. Double-click the new Bookmark to re-name it.

9. Save your dashboard by clicking the Save icon.

10. Toggle to another bookmark on the Bookmarks tab.
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11. Then toggle back to your newly added Bookmark. Not only will that Approver 1 be
selected, but all reports and data are filtered to those projects where he is the Approver 1.

2 . 2 DASHBOARD F ILTER ING

The dashboards in Explore have advanced filtering abilities to make viewing easier and more
customized.

You can filter the information on your dashboards on four different levels:
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Filter Definition

Visual Level Filters a single visual on a dashboard. You can select the
date range, account codes, approvers, etc. that you want
shown.

Page Level Filters all the visuals on a single page. You can use this to
filter by areas on the project, date range, executor, etc.

Report Level Filters all pages in a report. You can use this to filter a report
by project, date range, remaining MHrs, etc.

Drillthrough Used to focus on one aspect of the project. Any other page
or visual that contains this drillthrough value can be
redirected to this drillthrough page for a more focused and
up-close view.
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Drilling down on report data to the meta-data level, can assist in your analysis. Most of the
visualizations on the dashboards display data at a summary level. Drilling down into the visualizations
allows you to see the data at the detail level.

To enable us to view filtering and drill down data better, complete these preliminary steps.

Filter a dashboard (part 1)

1. Navigate to the Contract Dashboard, and then select Edit Dashboard from the Context
Menu (…) icon.

2. Save your new dashboard using File > Save As appending the Contract Dashboard file
name with your initials.

3. Close the Dashboards and Bookmarks slide-out panels to give yourself more room to
work.

4. Select a Project.

5. Select a Contract Status of All.

6. Select a Contract Type of All.

7. Select a Vendor Name of All.

8. Right-click on the Contract Overview tab, and then select Duplicate Page.

9. On the duplicate page, delete the following charts:
l # of Contracts by ERP Sync Status
l # of VCO’s by Status
l # of Payforms by Request Status

10. By either:
l Clicking the ellipses, and then selecting Remove, or
l Clicking on the chart, and then pressing the Delete button on your keyboard

11. Expand the width of the Fields panel.

12. Expand the # Contracts by Type chart.
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13. Click on each remaining chart to view Fields used.

14. On the # Contract by Type chart, click the Contracts Field panel, and then add Status
Hierarchy > Contract Status. Notice how the chart changes.
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15. Specifically, with the field added, you now have greater ability to filter the data.

2.2.1 Filtering options

# Filtering Option

1 Drill Up

2 Drill Down

3 Go to Next Level in the Hierarchy

4 Expand all Down one level in the Hierarchy

5 Filter

6 Focus Mode

7 More Options
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Navigate to the dashboard that you just created and select Edit dashboard from the Context menu
icon.
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l Note the four types of filters:

Filter Type Definition

1. Visual Level Filters on an individual visual.

2. Page Level Filters on every visual on the report page.

3. Report Level Filters on all pages in the report.

4. Drillthrough Filters on a single entity in the report.

For the remainder of this section, contract status data will be represented by the # of
value. Alternatively, if the toggle was changed, all data would be shown by Value. Similar
functioning toggles exist in other types of reports making it easier to view data in an altern-
ate format.

Having followed the previous steps, your screen should now look similar to this:
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Filter a dashboard (part 2)

1. Open the Filters panel.

2. Click on the # of Contracts by Type stacked bar chart.

3. Click on the Filters icon and notice you have no filters applied right now.

4. Under the Visualizations slide-out panel, click on the # of Contracts drop-down to view
details of that filter.

5. On the Visual Filters, click on the Contract Status drop-down, select Executed to apply
the filter.
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l Notice how this chart changes

6. Change the Contract Status to Select All.

7. Collapse the Contract Status filter.
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8. Under the filter Contract Type, select 2 options from your drop-down.

9. Within the chart, right-click and select Visual Table.

l The # of Contracts by Type chart now only appears, with the actual data for those
two contract types shown.

10. Add a third Contract Type, and see how the chart and data changes again.

11. Click Back to Report.
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12. Close the Contract Type filter.

13. Click File > Save to save this dashboard.

14. Open the # of Contracts filter.

15. Show items that are greater then 100 and less than 300.

16. Click Apply Filter.
l The newly filtered chart appears. In this case, Executed is greater than 300. Why do
482 Executed Contracts appear? Let’s drill down further to find out
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17. Click the Drill down icon.

18. Then click on the orange Executed row.
l The chart changes to Executed Service Agreements and Executed Rental
Agreements, both under 300

19. Click the Expand All Down One Level in the Hierarchy button.

InEight Inc.  |  Release 26.1 Page 75 of 92

Explore User Guide 2.2 Dashboard Filtering



l Now the chart changes to all Executed Contract Types greater than 100 and less
than 300

20. Right-click on the image and click Drill up.

21. Right-click on the # of Contracts Filter and select Clear filter.
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22. Under the Contract Status filter, change the drop down from Basic Filtering to Advanced
filtering.

23. Under Show Items when the value > contains type in cancelled or contains closed.

24. Click Apply filter.
l The chart now shows only Cancelled or Closed statuses

25. Click the Contract Status Clear filter icon.
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26. Click File > Save.

2.2.2 Page filtering

Two options of page filtering exist in Explore. The first is filtering on just this page (tab.)

From the Contract Fields panel, drag the checked Contract Status field onto Filters on this Page.

Select Closed from the Basic Filtering drop-down list.
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l Now all reports on this page only show contracts that have been Closed

Select the Remove Filter X icon.

2.2.3 Filter on all pages

The second type of page filter applies a filter across all pages (tabs).

Drag the same Contract > Contract Status data field onto Filters On All Pages.

Again choose the option of Closed from the drop-down list. Nothing will look different on this tab, only
when you select another tab will the change be obvious. For example, this is the Bid Packages tab,
where all charts only represent Closed projects.
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2.2.4 Go to the next level in the hierarchy

The final icon when filtering is the Go to Next level in the Hierarchy icon. When in a report and this
icon is clicked, the table filters down to the next level in the Hierarchy as shown in this Visualization:

Initially, data will be represented by Contract Status.

When the Go to Next level in the Hierarchy icon is selected, the chart will change to # of Contracts by
Contract Type.
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Throughout the Explore dashboard, there are multiple instances where you can hover over a
data-point to obtain a Type Tooltip pop-up showing drill down data.

Last Data Refresh: A time-stamp in the dashboard list indicates when the data in that
dashboard was last refreshed. This helps minimize the confusion about why some records may
or may not be present in your dashboard.
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CHAPTER 3 — EXPLORE MOB ILE
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3 . 1 MOB ILE APPL ICAT ION

The Explore mobile application gives you access to your reports and the ability to view dashboards
from a mobile device. This added convenience lets you analyze reporting data from anywhere, which
allows you to make informed and timely decisions.

After you log in to the application, the screen opens to show an alphabetical listing of the dashboards.

l All folders and favorites added in the web application also show in Explore mobile.

The following step-by-step shows how to pull up the Explore mobile dashboard.

Pull up a dashboard

1. Tap the Refresh icon to sync any changes you made in the web application.

2. Scroll through the list of dashboards and folders or use the Search function at the top to
find the dashboard you need.
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3. Tap a dashboard to open it.
l The screen will turn from portrait to landscape.

3.1.1 Manipulate a dashboard

In the dashboard, you can refresh the screen, zoom in and out, select different tabs, and modify filters
to personalize your view.

You cannot share or edit dashboards in the mobile application.

l Tap the Information icon to show additional information about the dashboard, such as the
owner of the dashboard and last data refresh time.

l Tap the ellipses, and then the Favorite icon to make the dashboard a favorite. This also
makes the dashboard a favorite in the web application.

l Tap the Menu icon. You can toggle between the dashboard and your account information
or sign out of the mobile application.

InEight Inc.  |  Release 26.1 Page 85 of 92

Explore User Guide 3.1 Mobile Application



The Sharing icons are visible but can only be activated in the web application.

3 . 2 V IDEO INDEX

This is an index of video transcript pages. For the full video gallery, see the main video page.

l API Documentation video

l Custom Dashboards video

l Dashboard Favorites video

l Dashboard Filtering video

l Dashboard Folders video

l Dashboard Sharing and Collaboration video

l Embed External Content video

l Explore Mobile App video

l Settings Page video

l Standard Dashboards video

3 . 3 EXPLORE FREQUENTLY ASKED
QUEST IONS

What is the Reporting data flow?

The following workflow shows the relationship between InEight applications, the Connected
Analytics database, and the Report and Explore applications (including reports, dashboards, and
APIs).
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When looking to integrate InEight data with our systems, can we use the Reporting APIs if the
Integration APIs don’t have the data we’re looking for?

No, using the Reporting APIs in place of the Integration APIs is not supported, nor is it
recommended.

Integration APIs source data directly from their respective product’s database, allowing data to
appear in the Integration APIs in real-time without a data lag.

Alternatively, the Reporting APIs read data from a consolidated database that aggregates data
from the different products’ databases rather than drawing directly from the source database.
This increases the likelihood that there could be a point of failure between the product source
database and reporting, causing the reporting data to be out of sync.

Also, in the acquisition of this data, there may be a refresh interval that occurs in the background
to pull data from the product source database to the reporting database. This opens you up to
the possibility that the data may not match what the product user interface reads. This potential
data latency can also make scheduling data pulls complicated, especially when you are looking to
support critical processes, such as payroll runs.

What is the difference between Explore and SelfService APIs?

SelfService APIs are designed to satisfy extraction requirements. These APIs more closely match
the source data, though we do some denormalization to combine IDs and text into the same table
and ensure field/table naming more closely matches the user interface. Records that have been
deleted or updated in the products’ user interface are soft-deleted in the database. These APIs
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will expose both “active” and “inactive” (soft-deleted) records. An example of this use case would
be writing ETL against the data to extract it into a data warehouse that is used to combine data
for reporting. However, it is important to note that these APIs can also be used for BI use cases,
such as connecting to Power BI.

The APIs prefixed with Explore are designed to satisfy more of a BI use case. These APIs report
only active and latest records as reflected in the system. And in some cases, they may have more
business logic implemented in the code behind them. They also will have naming conventions
similar to what is in the user interface of the InEight applications. An example of this use case
would be connecting in Power BI.

For the most part, Explore APIs will have a SelfService counterpart, and the documentation for
the SelfService API should apply to the Explore APIs, with some minor differences.

Can ETL be written against the APIs to bring data into a reporting environment?

Yes, this is possible. If you need your Client ID and Secret for your selected ETL tool, you can reach
out to InEight Support or your InEight representative.

Please note that troubleshooting errors and setting up connections for your ETL tools outside of
InEight is not included in our services.

What are the refresh times on the APIs?

Currently, the refresh time of reporting data varies by product. Most products' data refresh
utilizes an incremental load methodology. This means, on an interval basis, our database looks for
changes in the product databases based on the modified date on the records. Based on the
detected changes, the reporting database updates accordingly.

Some InEight Applications have implemented the architecture for entity change on some or all of
their database entities.

An example to entity change is the setting “When the user updates Current Estimate Total Cost of
a Cost Item, this change will be reflected within the next 5 minutes in the corresponding
SelfService_Control_CurrentEstimate reporting api”, whereas there are APIs that only refresh
once a day. All of InEight Schedule APIs and the 5 InEight Plan APIs (listed below) fall into this
category.

That means for those entities we can leverage a trigger-based refresh. This means the fresh data
will be reflected in the reports and APIs in near-real-time (five minutes or less).

The rule of thumb, however, is twenty minutes or less for all reports and APIs, unless otherwise
noted in the API or report documentation.
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There are 5 APIs that are on a daily refresh cadence (this applies to these APIs only and does not
have any bearing on reports in Report):

l SelfService_Plan_Timecard

l SelfService_Plan_WeeklyTimesheetVersion

l SelfService_Plan_DailyPlanHoursResourceVersion

l SelfService_Plan_DailyPlanHoursResourceDetailVersion

l SelfService_Plan_DailyPlanHoursPayrollIndicatorVersion

l Additionally, Schedule APIs are on a daily refresh cadence.

l The refresh cadence of APIs is published in our API documents.

Additionally, Schedule APIs are on a daily refresh cadence.

The refresh cadence of APIs is published in our API documents.

What is pagination and what is the pagination for the reporting APIs?

Pagination is a method of segmenting the data returned by an API in an attempt to not
overwhelm it with larger datasets.

All of the reporting APIs have a pagination setting, and most are set to 50,000. However, some of
the larger APIs are set to 5,000. This is also noted in the API documentation.

Are there limits on how many API calls can be made?

We currently impose a rate limit of 50 calls per minute on each API.

Are there permissions needed to access the Reporting APIs?

Yes, permissions are required to access the Reporting APIs. They can be found in Suite
administration > Roles and permissions > Explore > Reporting APIs. These permissions are split
out by product.

How do I connect to Reporting APIs?

You can access Reporting APIs from the following link: Reporting APIs

What is the data refresh interval on the Explore dashboards?

The Explore dashboards that come with the system will refresh 1-3 times per day. These refreshes
can be scheduled in Organization Settings > Explore. You can also initiate on-demand refreshes
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on this page but there is a maximum of five refreshes per day per dashboard. You need to be an
Organization Admin with the organization and have the Project > Access Explore settings
permission. The Explore Organization settings page also has an option to kick off an on-demand
refresh for each dataset.

Each custom-built dashboard refreshes when the system dashboard it was built from refreshes.

What kind of security is applied to the dashboards?

We apply the same project-level security to the dashboards that we do on reports. This means
when users access a dashboard, they can only see data for projects they have assignments on.

The dashboard visibility itself is controlled at the Organization level, meaning that when a
dashboard has its visibility turned on or off on the Explore Settings page, this applies for the
whole organization.

There is an additional InEight Platform permission for Explore that will control a user’s available
dashboards, so they only see dashboards that have been shared with them as an individual.

This can be found in the Explore section under Roles and Permissions

Why are some dashboards deployed early or hidden?

Our dashboard release strategy is to deploy dashboards to clients a release before they
technically “go-live”, referring to these early releases as “Preview” releases. These Preview
releases give you a “sneak peek” and an opportunity to test the new functionality and provide
feedback before the dashboards officially go live.

Users can make these dashboards visible by navigating to the Explore Settings page and toggling
the visibility from Off to On. This will apply for the whole organization. Note that you will need an
additional Platform permission to access the Explore Settings page.

l If you turn on the visibility for a dashboard before it has gone live (as a Preview dashboard),
when the dashboard goes live, it will stay visible.

l If you turn the dashboard visibility on and then back off, it will stay hidden when the
dashboard goes live.

l If you leave the dashboard visibility set to “Hide” and don’t touch it while it’s in Preview,
then the dashboard will become visible upon going live.
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What Permissions are required for the API Generator?

You will need the following permissions from Platform > Suite administration > Roles and
permissions:

l Explore > API Generator

l For pulling data from the Completions or Compliance application

l Explore > Reporting APIs > View Completions web APIs

l Explore > Reporting APIs > View Compliance APIs

You will also need module-level permissions assigned in Compliance or Web Completions.

What is the refresh rate for API Generator data?

Due to the complexity of manipulations to get the data in the correct format, data in the APIs is
updated daily. The data is therefore staged to avoid running into performance and timeout issues
when you access your APIs.

Can I create an API with multiple forms?

No, this feature is specific only to singular forms.

How do I troubleshoot different errors received when connecting to the APIs?

401: Unauthorized - generated token isn't valid or available

l Try regenerating the authentication token.

404: Resource not found

l APIM has been updated to the latest version and your environment is on a previous
version. This will be resolved when your environment is upgraded.

l The API in question has been removed from our codebase, but not APIM. This does not
occur often and it will be documented in the Release Notes if it happens.

500: Internal Server Error

l Authentication token isn't valid.

l There could have been a column modification, which will also be documented in the
Release Notes.

l Transient/Intermittent Azure related issue.

502: Bad Gateway
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l This is a timeout issue. The system has two minutes to run the API query and return data.

l Could be a data volume issue. Try limiting the API call with some kind of filtering.

l Reduce simultaneous calls.
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